Zum Hauptinhalt springen

GoDaddy Hilfe

Beheben von WordPress-Plugin-Fehlern

Führen Sie folgende Schritte aus, um Plugin-Fehler in WordPress zu beheben.

Bereiten Sie Ihre WordPress-Website für die Fehlersuche vor:

  1. Sie sollten immer ein Backup Ihrer Website erstellen, bevor Sie eine Fehlersuche starten.
  2. Deaktivieren Sie alle WordPress-Plugins und insbesondere alle Caching-Plugins.
  3. Deaktivieren Sie WP_CACHE, sofern Ihre Website es verwendet.

Nachvollziehen eines WordPress-spezifischen PHP-Fehlers

Wenn Ihre vorherigen Schritte zur Fehlersuche ergeben haben, dass ein PHP-Fehler aufgetreten ist, dann versuchen Sie anhand folgender Tabelle, die Fehlerursache nachzuvollziehen.


Fehlertyp Definition und weitere Schritte
E_ERROR Dies ist ein schwerwiegender Fehler, der einen Abbruch der Skriptausführung bewirkt. Solche Fehler werden normalerweise durch Aufruf eines nicht vorhandenen Objekts wie einer Klasse oder Funktion verursacht. Ursache sind hierbei häufig Versionsinkompatibilitäten. Aktualisieren Sie Ihre WordPress-Version sowie Themes und Plugins.
E_WARNING Dies ist eine zur Laufzeit ausgegebene Warnung, die nicht zum Abbruch der Skriptausführung führt. Hierbei handelt es sich potenziell um Probleme, die zwar auftreten, aber die Verarbeitung von PHP nicht beeinträchtigen. Sie enthalten häufig Warnungen wegen veralteter Versionen. Dies lässt darauf schließen, dass Ihr Code möglicherweise eine veraltete PHP-Version verwendet und aktualisiert werden muss. Eine Warnung in Ihren PHP-Protokolldateien muss nicht unbedingt mit dem aufgetretenen Problem in Zusammenhang stehen.
E_PARSE Dies ist ein Parsing-Fehler, der bei der Kompilierung aufgetreten ist. Er weist in der Regel auf einen PHP-Syntaxfehler hin, z. B. ein fehlendes Semikolon, fehlerhafte Klammersetzung, eine öffnende oder schließende geschweifte Klammer {} oder irgendeinen anderen Syntaxfehler. Sie sollten die in der Fehlermeldung angegebene Datei und Zeile überprüfen und nach möglichen Syntaxfehlern suchen.
E_NOTICE Dies ist ein zur Laufzeit ausgegebener Hinweis, der durch einen Fehler im Code verursacht wird. Dabei handelt es sich normalerweise um PHP-Fehler, die nicht zum Abbruch der Skriptausführung führen. Solche Fehler können darauf hindeuten, dass ein Problem im Code vorliegen könnte, es kann sich aber auch um eine ganz normale Skriptfunktion handeln. Eine häufige Ursache ist die Verwendung einer PHP-Variablen, die nicht definiert ist. Ein solcher Hinweis in Ihren PHP-Protokolldateien muss nicht unbedingt mit dem aufgetretenen Problem in Zusammenhang stehen.

Aktualisieren Ihrer WordPress-Komponenten

Wenn Ihre WordPress-Version, Themes oder Plugins aktualisiert werden, kann dies zu Konflikten führen. Sie können Ihre Website dann durch Aktualisierung aller WordPress-Komponenten wieder in den Normalzustand versetzen.

Aktualisieren Sie die folgenden Komponenten auf die jeweils neuesten Versionen:

Ähnliche Schritte

Weitere Informationen